[FFmpeg-devel] support for reading / writing encrypted MP4 files
Eran Kornblau
eran.kornblau at kaltura.com
Tue Dec 15 12:02:28 CET 2015
> >
> > +struct AVAESCTR;
>
> Is this needed?
>
Indeed compiles for me without it, I matched the existing code in aes.h, and in general I prefer to define the structs in advance.
If you prefer that I will remove it, please let me know
> > + subsample_count = AV_RB16(sc->cenc.auxiliary_info_pos);
> > + sc->cenc.auxiliary_info_pos += sizeof(uint16_t);
>
> I find the following significantly easier to read and understand:
>
> subsample_count = AV_RB16(sc->cenc.auxiliary_info_pos);
> sc->cenc.auxiliary_info_pos += 2;
>
> But this may just be me, so feel free to ignore.
>
When it's a simple type my preference is to go with the sizeof, when it becomes slightly more than that, e.g.:
+
+ ctx->auxiliary_info_size += 6;
+ ctx->subsample_count++;
+
I use a number (not sizeof(uint16_t) + sizeof(uint32_t)). But again it's all a matter of personal preference,
if you want me to change it, let me know.
> I suspect a fate test will be needed but this may be an
> independent patch.
>
Ok, I will write one after this one gets approved :-)
> Thank you, Carl Eugen
>
Thanks !
Eran
More information about the ffmpeg-devel
mailing list