[FFmpeg-devel] vda: fix h64 decoding, vda wants the entire buffer

Xidorn Quan quanxunzhen at gmail.com
Wed Apr 1 13:56:12 CEST 2015

On Wed, Apr 1, 2015 at 10:10 PM, Hendrik Leppkes <h.leppkes at gmail.com>

> On Wed, Apr 1, 2015 at 12:40 PM, Rainer Hochecker <fernetmenta at online.de>
> wrote:
> > vda wants the entire buffer with all info. it has no other means to
> deliver
> > picture parameters.
> > according to documentation start_frame can pass the entire buffer
> This doesn't make much sense. If I follow that argument, then vda
> would never have worked, at all. How is it that it does work for many
> other people, presumably including the author of this code?

I haven't looked into the code for a long time. But what I can tell is, VDA
only worked
for really limited cases when I played with it. For example, it required
all extra data,
also it only recognized 'AVC1' as fourcc, 'H264' would make it failed.

I'd recommend you to try to use VT instead of VDA. In new OS X systems, VDA
just a simple wrapper of VT. VT is probably more powerful (though I haven't
tried it myself.)

- Xidorn

More information about the ffmpeg-devel mailing list