[FFmpeg-devel] [PATCH 1/2] avutil: Add av_get_time_base{_q, }() and deprecate AV_TIME_BASE{_Q, }

Derek Buitenhuis derek.buitenhuis at gmail.com
Mon Dec 30 20:40:27 CET 2013

On 12/30/2013 4:47 PM, Clément Bœsch wrote:
> The purpose of the second one was "consistency". I don't mind
> particularly.

I would prefer to have both for consistency. Having one but not the other
violates the principle of least astonishment[1].

[1] http://en.wikipedia.org/wiki/Principle_of_least_astonishment

- Derek

More information about the ffmpeg-devel mailing list