[FFmpeg-devel] [PATCH] windres: Track dependencies

James Almer jamrial at gmail.com
Mon Dec 9 03:30:57 CET 2013

On 08/12/13 10:59 PM, Michael Niedermayer wrote:
> On Mon, Dec 09, 2013 at 02:53:39AM +0100, Michael Niedermayer wrote:
>> On Sun, Dec 08, 2013 at 10:42:43PM -0300, James Almer wrote:
>>> On 08/12/13 10:17 PM, Michael Niedermayer wrote:
>>>> aplied
>>>> thanks
>>> I was intending to send an actual patch with a less hack-y version of this i came up 
>> i didnt want to leave it broken

I know. It's not like you could know I'd come up with a different fix. I just wanted to 
mention i did as much and was about to send it.

>>> with after you confirmed it worked for your system.
>> its a virtualbox that isnt that fast so i thought it would be enough
>> if hendrik confirmed that it fixes it

You're using ccache, and i didn't know if windres accepted it as preprocessor or if this 
fix would affect it in a different way.
I installed it on my VM before sending the proper fix and it worked.

> and i couldnt reproduce an issue outside the virtualbox ....

In the end I could reproduce this problem when cross-compiling on my Gentoo VM, but not 
on my Msys environment.
Not sure why that extra @ broke it in the former but not the latter. Maybe some 
differences in the command-line interpreter...


More information about the ffmpeg-devel mailing list