[FFmpeg-devel] [PATCH 3/3] targaenc: Use named TGA_RLE constant instead of magic number

Bobby Bingham uhmmmm at gmail.com
Tue Sep 18 07:38:32 CEST 2012


Signed-off-by: Bobby Bingham <uhmmmm at gmail.com>
---
 libavcodec/targaenc.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/libavcodec/targaenc.c b/libavcodec/targaenc.c
index a7dce3a..2f22e94 100644
--- a/libavcodec/targaenc.c
+++ b/libavcodec/targaenc.c
@@ -144,7 +144,7 @@ static int targa_encode_frame(AVCodecContext *avctx, AVPacket *pkt,
 
     /* if that worked well, mark the picture as RLE compressed */
     if(datasize >= 0)
-        pkt->data[2] |= 8;
+        pkt->data[2] |= TGA_RLE;
 
     /* if RLE didn't make it smaller, go back to no compression */
     else datasize = targa_encode_normal(out, p, bpp, avctx->width, avctx->height);
-- 
1.7.12



More information about the ffmpeg-devel mailing list