[FFmpeg-devel] [PATCH 04/13] src_buffer: introduce av_buffersrc_add_ref().

Nicolas George nicolas.george at normalesup.org
Wed May 2 12:16:35 CEST 2012

Le primidi 11 floréal, an CCXX, Stefano Sabatini a écrit :
> OK, but I suppose "bufref" or "ref" is more suited since it will
> support also audio buffers.

I gave my reason for sticking with ref in the parent message: in short,
"buffer" is already present, and shorter names, as long as they stay
self-contained, are more readable.

> Note: this is not very consistent with av_buffersink_get_buffer_ref(),
> we can change this to a longer variant or rename
> av_buffersink_get_buffer_ref() to av_buffersink_get_ref(), I'm fine
> with both options.

I noted that as a TODO.

> Should be fine otherwise if tested, thanks.

Thanks, I intend to push soon the parts that were approved.


  Nicolas George
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://ffmpeg.org/pipermail/ffmpeg-devel/attachments/20120502/27726ee7/attachment.asc>

More information about the ffmpeg-devel mailing list