[FFmpeg-devel] [PATCH 02/11] ffprobe: use av_mpegtc_to_timecode_string().

Clément Bœsch ubitux at gmail.com
Mon Jan 23 16:45:39 CET 2012


On Wed, Jan 18, 2012 at 11:05:20PM +0100, Alexander Strasser wrote:
> Hi,
> 
> Clément Bœsch wrote:
> > On Mon, Jan 16, 2012 at 07:01:46PM +0100, Stefano Sabatini wrote:
> > > On date Monday 2012-01-16 17:30:05 +0100, Clément Bœsch encoded:
> > > > From: Clément Bœsch <clement.boesch at smartjog.com>
> > > > 
> > > > ---
> > > >  ffprobe.c |   11 ++++-------
> > > >  1 files changed, 4 insertions(+), 7 deletions(-)
> > > > 
> > > > diff --git a/ffprobe.c b/ffprobe.c
> > > > index 61c66ae..55cf43a 100644
> > > > --- a/ffprobe.c
> > > > +++ b/ffprobe.c
> > > > @@ -32,6 +32,7 @@
> > > >  #include "libavutil/opt.h"
> > > >  #include "libavutil/pixdesc.h"
> > > >  #include "libavutil/dict.h"
> > > > +#include "libavutil/timecode.h"
> > > >  #include "libavdevice/avdevice.h"
> > > >  #include "libswscale/swscale.h"
> > > >  #include "libswresample/swresample.h"
> > > > @@ -1454,13 +1455,9 @@ static void show_stream(WriterContext *w, AVFormatContext *fmt_ctx, int stream_i
> > > >              else   print_str_opt("pix_fmt", "unknown");
> > > >              print_int("level",   dec_ctx->level);
> > > >              if (dec_ctx->timecode_frame_start >= 0) {
> > > > -                uint32_t tc = dec_ctx->timecode_frame_start;
> > > > -                print_fmt("timecode", "%02d:%02d:%02d%c%02d",
> > > > -                          tc>>19 & 0x1f,              // hours
> > > > -                          tc>>13 & 0x3f,              // minutes
> > > > -                          tc>>6  & 0x3f,              // seconds
> > > > -                          tc     & 1<<24 ? ';' : ':', // drop
> > > > -                          tc     & 0x3f);             // frames
> > > 
> > > > +                char tcbuf[AVTIMECODE_STR_LEN];
> > > 
> > > Unrelated nit+bikeshed: don't know if this is already public, but
> > > maybe the AV_* convenction should be favored over AV* (I mean
> > > AVTIMECODE.. -> AV_TIMECODE...).
> > > 
> > 
> > Nothing is decided and upstream yet. I'm fine with AV_TIMECODE over
> > AVTIMECODE; I'll do the rename on my local patchset tomorrow.
> 
>   I like AV_TIMECODE too.
> 
>   YAN(yet another nit): AV_TIMECODE_STR_SIZE would fit better. If I
> see LEN I might jumpt to the conclusion that +1 is needed (e.g. like
> when using strlen() of libc).
> 

Sure OK, will be updated in the next patchset.

-- 
Clément B.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 490 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-devel/attachments/20120123/235ac836/attachment.asc>


More information about the ffmpeg-devel mailing list