[FFmpeg-devel] [PATCH] lavfi: unify asink_buffer and vsink_buffer API

Stefano Sabatini stefano.sabatini-lala at poste.it
Thu Sep 1 12:36:28 CEST 2011


On date Wednesday 2011-08-31 21:59:35 +0200, Michael Niedermayer encoded:
> On Wed, Aug 31, 2011 at 05:50:00PM +0200, Stefano Sabatini wrote:
[...]
> > From 2d89fad987b948a8eec32e39fdf715153518e464 Mon Sep 17 00:00:00 2001
> > From: Stefano Sabatini <stefano.sabatini-lala at poste.it>
> > Date: Thu, 18 Aug 2011 16:21:47 +0200
> > Subject: [PATCH] lavfi: unify asink_buffer and vsink_buffer API
> > 
> > The new API is more generic (no distinction between audio/video for
> > pulling frames), and avoids code duplication.
> > 
> > A backward compatibility layer is kept for avoiding tools ABI breaks
> > (only for the video binary interface, audio interface was never used
> > in the tools).
> 
> looks good

Last nits.

In the previous patch:
buffersink
abuffersink
avfilter_buffersink_params_alloc
avfilter_abuffersink_params_alloc
AVFilterBufferSinkParams
AVFilterABufferSinkParams
av_sink_buffer_get_buffer_ref
AV_SINK_BUF_FLAG*

I tried to implement a more consistent scheme, now we have:
buffersink
abuffersink
av_buffersink_params_alloc
av_abuffersink_params_alloc
AVBufferSinkParams
AVABufferSinkParams
av_buffersink_get_buffer_ref
AV_BUFFERSINK_FLAG_*

Next step would be to rename
vsink_buffer.c -> sink_buffer.c (implementation, consistent with the other file names)
vsink_buffer.h -> buffersink.h

I'm going to commit soon (togheter with the file renames) if I see no
comments.
-- 
FFmpeg = Fiendish and Fascinating Multipurpose Powerful Evangelical Geek
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-lavfi-unify-asink_buffer-and-vsink_buffer-API.patch
Type: text/x-diff
Size: 28301 bytes
Desc: not available
URL: <http://ffmpeg.org/pipermail/ffmpeg-devel/attachments/20110901/f3b47fba/attachment.bin>


More information about the ffmpeg-devel mailing list