[FFmpeg-devel] [PATCH] lavf: move ff_get_v from avio.h to avio_internal.h
Michael Niedermayer
michaelni
Thu Mar 10 20:09:42 CET 2011
On Thu, Mar 10, 2011 at 07:07:46PM +0100, Anton Khirnov wrote:
> And rename it to ffio_read_varlen.
> ---
> libavformat/avio.h | 2 -
> libavformat/avio_internal.h | 2 +
> libavformat/aviobuf.c | 2 +-
> libavformat/mpc8.c | 9 +++--
> libavformat/nutdec.c | 85 ++++++++++++++++++++++---------------------
> 5 files changed, 51 insertions(+), 49 deletions(-)
>
> diff --git a/libavformat/avio.h b/libavformat/avio.h
> index 4b4c0b6..d4d9f82 100644
> --- a/libavformat/avio.h
> +++ b/libavformat/avio.h
> @@ -577,8 +577,6 @@ unsigned int avio_rb24(AVIOContext *s);
> unsigned int avio_rb32(AVIOContext *s);
> uint64_t avio_rb64(AVIOContext *s);
>
> -uint64_t ff_get_v(AVIOContext *bc);
> -
> #if FF_API_OLD_AVIO
> /**
> * @deprecated Use AVIOContext.seekable field directly.
> diff --git a/libavformat/avio_internal.h b/libavformat/avio_internal.h
> index 3abb619..2e0b94c 100644
> --- a/libavformat/avio_internal.h
> +++ b/libavformat/avio_internal.h
> @@ -61,4 +61,6 @@ static av_always_inline void ffio_wfourcc(AVIOContext *pb, const uint8_t *s)
> */
> int ffio_rewind_with_probe_data(AVIOContext *s, unsigned char *buf, int buf_size);
>
> +uint64_t ffio_read_varlen(AVIOContext *bc);
IMHO the name is wrose
[...]
--
Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB
Into a blind darkness they enter who follow after the Ignorance,
they as if into a greater darkness enter who devote themselves
to the Knowledge alone. -- Isha Upanishad
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20110310/a7b9d35f/attachment.pgp>
More information about the ffmpeg-devel
mailing list