[FFmpeg-devel] [PATCH] swscale: add generic yuv2yuv wrapper function

Michael Niedermayer michaelni
Tue Sep 14 17:39:40 CEST 2010

On Sat, Sep 11, 2010 at 02:15:39AM -0300, Ramiro Polla wrote:
> This is a patch series that cleans the yuv2yuv functions inside
> rgb2rgb.c a bit (and removes their global function pointers).
> Now I'm stuck in a bikeshed issue. There is one rgb2yuv function in
> there (rgb24toyv12). So "yuv2yuv_func" and "Yuv2YuvFunc" don't sound
> too great anymore. How should it be named?

rgb->yuv needs a bit more work anyway as there are several yuv types but
it hardcodes one

about the patch that looks good after a quick look and i assume its tested

> I also plan on having another function pointer in the context to
> simplify rgb2rgb (they'll take another set of parameters though). I'm
> thinking of adding a "void *priv_data" to the context so that at some
> point later on it will be possible to split the fields in the context
> and only allocate/initialize them depending on the scaler chosen.
> Would this be a good place to put the function pointers?

i dunno, a void * pointer feels a bit too black boxish to me

Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

The real ebay dictionary, page 2
"100% positive feedback" - "All either got their money back or didnt complain"
"Best seller ever, very honest" - "Seller refunded buyer after failed scam"
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20100914/a5bd7230/attachment.pgp>

More information about the ffmpeg-devel mailing list