[FFmpeg-devel] [PATCH] move av_parse_color() to libavcore
Aurelien Jacobs
aurel
Sun Nov 14 23:22:36 CET 2010
On Sat, Oct 23, 2010 at 08:28:06PM +0200, Michael Niedermayer wrote:
> On Sat, Oct 23, 2010 at 06:27:59PM +0200, Aurelien Jacobs wrote:
> > On Sat, Oct 23, 2010 at 06:25:59PM +0200, Aurelien Jacobs wrote:
> > > Hi,
> > >
> > > I need to use the av_parse_color() function in the upcomming SubRip
> > > decoder (especially to decode those html named colors).
> > > So the attached patch move this function from libavfilter to libavcore.
> > > To simplify review, this patch don't contain removal of
> > > libavfilter/parseutil.* but I will do the svn rm while committing.
> >
> > Hum... Here is the patch.
> >
> > Aurel
> > libavcore/parseutils.c | 272 +++++++++++++++++++++++++++++++++++++++++++++++
> > libavcore/parseutils.h | 19 +++
> > libavfilter/Makefile | 1
> > libavfilter/vf_drawbox.c | 2
> > libavfilter/vf_frei0r.c | 2
> > libavfilter/vf_pad.c | 1
> > 6 files changed, 293 insertions(+), 4 deletions(-)
> > 62f8c66e68b5cffb991d1ba90cbfad4fe2cd8f53 parse_color.diff
> > Index: libavcore/parseutils.h
> > ===================================================================
> > --- libavcore/parseutils.h (revision 25528)
> > +++ libavcore/parseutils.h (working copy)
> > @@ -50,4 +50,23 @@
> > */
> > int av_parse_video_rate(AVRational *rate, const char *str);
> >
> > +/**
> > + * Put the RGBA values that correspond to color_string in rgba_color.
> > + *
> > + * @param color_string a string specifying a color. It can be the name of
> > + * a color (case insensitive match) or a 0xRRGGBB[AA] sequence,
> > + * possibly followed by "@" and a string representing the alpha
> > + * component.
> > + * The alpha component may be a string composed by "0x" followed by an
> > + * hexadecimal number or a base-10 number between 0 and 255, or a
> > + * decimal number between 0.0 and 1.0, which represents the opacity
> > + * value (0/0x00/0.0 means completely transparent, 255/0xff/1.0
> > + * completely opaque).
>
> I think the double meaning of 1 should be fixed 1==1.0
Now that this issue is fixed and that av_parse_color() is improved to
be more useful, here is an updated patch moving it to libavcore.
Again, for readability, this patch don't contain the
svn rm libavfilter/parseutils.*
Aurel
-------------- next part --------------
A non-text attachment was scrubbed...
Name: move_parse_color.diff
Type: text/x-diff
Size: 17190 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20101114/20f62417/attachment.diff>
More information about the ffmpeg-devel
mailing list