[FFmpeg-devel] [PATCH] Change broken -Werror=implicit flag in configure into working flag

Måns Rullgård mans
Sun Jun 27 13:48:36 CEST 2010


Martin Storsj? <martin at martin.st> writes:

> On Sun, 27 Jun 2010, M?ns Rullg?rd wrote:
>
>> > Stefano sent a patch doing that, making both ff_url_split and ff_url_join 
>> > public, that stalled in a discussion on details regarding ff_url_join. 
>> > The part making ff_url_split public should be ok as far as I remember, 
>> > though.
>> 
>> ff_url_split() parts of the patch attached.
>
>> diff --git a/libavformat/utils.c b/libavformat/utils.c
>> index e33cb50..ed02f0f 100644
>> --- a/libavformat/utils.c
>> +++ b/libavformat/utils.c
>> @@ -3493,11 +3493,32 @@ void av_pkt_dump_log(void *avcl, int level, AVPacket *pkt, int dump_payload)
>>      pkt_dump_internal(avcl, NULL, level, pkt, dump_payload);
>>  }
>>  
>> +#if LIBAVFORMAT_VERSION_MAJOR < 53
>> +/**
>> + * @deprecated Use av_url_split() instead.
>> + */
>> +attribute_deprecated
>>  void ff_url_split(char *proto, int proto_size,
>>                    char *authorization, int authorization_size,
>>                    char *hostname, int hostname_size,
>>                    int *port_ptr,
>>                    char *path, int path_size,
>> +                  const char *url);
>> +{
>> +    av_url_split(proto, proto_size,
>> +                 authorization, authorization_size,
>> +                 hostname, hostname_size,
>> +                 port_ptr,
>> +                 path, path_size,
>> +                 url);
>> +}
>> +#endif
>> +
>
> Umm, this doesn't seem to compile for me at least.

Nor for me :-)  I've fixed it locally though.

> I guess the main bikeshed question is whether it should be named 
> av_url_split or simply url_split (since we have a family of public 
> functions named simply url_*). Ronald?

That family is badly named.  The url_ prefix is rather common in
various apps and libraries, and the risk of a clash is substantial.
If anything, the others should be renamed.

> In lavf/internal.h, there's a few mentionings of ff_url_split that need to 
> be changed accordingly too, and one use of ff_url_split in lavf/mmst.c 
> that needs changing, too.

Yeah, I just noticed.

-- 
M?ns Rullg?rd
mans at mansr.com



More information about the ffmpeg-devel mailing list