[FFmpeg-devel] [fix-multiple-filter-chain.patch PATCH 3/3] Cosmetics: rename enc -> avctx in opt_input_file(), the variable refer to a *decoder*, the old name was misleading.
Måns Rullgård
mans
Sat Jul 17 13:13:25 CEST 2010
Stefano Sabatini <stefano.sabatini-lala at poste.it> writes:
> On date Friday 2010-07-09 16:11:12 +0200, Michael Niedermayer encoded:
>> On Fri, Jul 09, 2010 at 12:56:24AM +0200, Stefano Sabatini wrote:
>> > On date Wednesday 2010-07-07 20:26:15 +0200, Michael Niedermayer encoded:
>> > > On Wed, Jul 07, 2010 at 08:03:29PM +0200, Stefano Sabatini wrote:
>> > > > ---
>> > > > ffmpeg.c | 44 ++++++++++++++++++++++----------------------
>> > > > 1 files changed, 22 insertions(+), 22 deletions(-)
>> > >
>> > > if its a decoder iz should be called dec
>> >
>> > Sorry the commmit message was wrong, the variable is a decoder
>> > *context* not a decoder, in this regards the use of avctx makes sense.
>>
>> dec= DEcoderContext then.
>
> That would be inconsistent with other parts of ffmpeg.c (and most
> FFmpeg code). Also the more natural interpretation of dec is DECoder.
So call it dctx and be done with it.
--
M?ns Rullg?rd
mans at mansr.com
More information about the ffmpeg-devel
mailing list