[FFmpeg-devel] [implement-pixdesctest PATCH] Rename read_line() and write_line() to av_read_image_data_line and av_write_image_data_line().
Måns Rullgård
mans
Wed Jul 7 23:41:27 CEST 2010
Stefano Sabatini <stefano.sabatini-lala at poste.it> writes:
> The old names were not av_ prefixed, and they were causing linking
> failure on many platforms.
> ---
> libavfilter/vf_pixdesctest.c | 4 ++--
> libavutil/pixdesc.c | 4 ++--
> libavutil/pixdesc.h | 8 ++++----
> 3 files changed, 8 insertions(+), 8 deletions(-)
>
> diff --git a/libavfilter/vf_pixdesctest.c b/libavfilter/vf_pixdesctest.c
> index 871be30..3c1dab3 100644
> --- a/libavfilter/vf_pixdesctest.c
> +++ b/libavfilter/vf_pixdesctest.c
> @@ -90,13 +90,13 @@ static void draw_slice(AVFilterLink *inlink, int y, int h, int slice_dir)
> int y1 = c == 1 || c == 2 ? y>>priv->pix_desc->log2_chroma_h : y;
>
> for (i = y1; i < y1 + h1; i++) {
> - read_line(priv->line,
> + av_read_image_data_line(priv->line,
New name seems a bit long. What would you read/write if not data?
--
M?ns Rullg?rd
mans at mansr.com
More information about the ffmpeg-devel
mailing list