[FFmpeg-devel] [RFC] Rename libavformat/rtp_* to rtpenc_* and rtpdec_*

Martin Storsjö martin
Sun Jan 17 10:36:34 CET 2010

On Wed, 13 Jan 2010, Luca Barbato wrote:

> On 01/10/2010 02:02 AM, Luca Abeni wrote:
> >> Opinions on such a rename?
> > 
> > Fine by me. Let's wait a little bit for other people's opinions, and
> > then I'll commit the rename.
> I'm  fine with it as well

A small note regarding this: rtp_h264.h defines

void ff_rtp_send_h264(AVFormatContext *s1, const uint8_t *buf1, int size);

which belongs to the encoder/packetizer part. The same function is also 
defined in rtpenc.h and never used from rtp_h264.h, so I guess it can be 
removed from rtp_h264.h before/after renaming that file to rtpdec_h264.h.

// Martin

More information about the ffmpeg-devel mailing list