[FFmpeg-devel] [PATCH] Move CPU detection to libavutil and cleanup

Janne Grunau janne-ffmpeg
Wed Aug 25 13:27:26 CEST 2010

On Tue, Aug 24, 2010 at 01:12:00AM +0200, Stefano Sabatini wrote:
> Updated with a less absurd name and with actually moving the code (not
> only the declaration of the interface) from libavcodec to libavutil.
> I preferred to put all the code in a single cpuid.c file rather than
> split the code in various x86/ppc/arm, also because this way it looked
> simpler.
> FF_MM_* flags also maybe should be renamed something like:
> or maybe:

if we rename them after a major bump, we should fix FF_MM_MMX and
FF_MM_ALTIVEC being defined to the same value. While a cpu with both
seems unlikey it had bitten me while implementing real runtime cpu
detection in libswscale/libpostproc.


More information about the ffmpeg-devel mailing list