[FFmpeg-devel] [PATCH] #define LAVF_API_MAX_STREAMS

Reimar Döffinger Reimar.Doeffinger
Wed Aug 18 08:10:09 CEST 2010

On Tue, Aug 17, 2010 at 09:34:50PM +0200, Aurelien Jacobs wrote:
> On Tue, Aug 17, 2010 at 07:19:47AM -0400, Ronald S. Bultje wrote:
> > > Overall, this is meant to ease API transition an major bump, and to
> > > increase tests code coverage.
> > 
> > Your patch doesn't do any of the above yet. Are you volunteering? :-).
> > They are good ideas.
> I volunteer to add proper defines for each of the currently ongoing
> transition, to test those transitions, and to demote to one which are
> not ready to v54 instead of v53.
> I hope somebody will catch this on the fly to integrate it into fate...

I do think the naming is rather bad, using FF_ would have made clear
it is for internal use only, like this you should at least document
that applications shouldn't check for these (or should they?
Then we'd have to keep these for "forever"?)

More information about the ffmpeg-devel mailing list