[FFmpeg-devel] [PATCH] Add DPX decoder rev-9

Jimmy Christensen jimmy
Mon May 25 11:01:58 CEST 2009


On 2009-05-25 10:24, Diego Biurrun wrote:
> On Mon, May 25, 2009 at 08:54:12AM +0200, Jimmy Christensen wrote:
>>
>> --- libavcodec/dpx.c	(revision 0)
>> +++ libavcodec/dpx.c	(revision 0)
>> @@ -0,0 +1,182 @@
>> +/*
>> +static unsigned int read32(const uint8_t **ptr, int is_big)
>> +{
>> +	unsigned int temp;
>> +	if(is_big)
>
> if (
>
>> +		temp = AV_RB32(*ptr);
>
> tabs, more below
>

whoops, sorry about that :) fixed

>> +#define RED10(x) ((x&  0xFFC00000)>>  22)
>> +#define GREEN10(x) ((x&  0x003FF000)>>  12)
>> +#define BLUE10(x) ((x&  0x00000FFC)>>  2)
>
> This would be more readable aligned.
>

I agree. Done.

>> +static av_cold int dpx_init(AVCodecContext *avctx)
>> +{
>> +}
>> +
>> +static av_cold int dpx_end(AVCodecContext *avctx)
>> +{
>> +}
>
> The canonical names for these functions are decode_init and decode_end.

fixed
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ffmpegDPX-rev10.diff
Type: text/x-patch
Size: 8561 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20090525/89843a62/attachment.bin>



More information about the ffmpeg-devel mailing list