[FFmpeg-devel] [PATCH] Yamaha SMAF decoder supports MA-2/MA-3/MA-5/MA-7
Vitor Sessak
vitor1001
Sun Jun 28 16:43:35 CEST 2009
?????????? ????????? wrote:
> 2009/6/28 Vitor Sessak <vitor1001 at gmail.com>
>
>> + /* Make sure it's followed by an Awa chunk, aka wave data */
>>>>> + if ((tag & 0xffffff) != MKTAG('A', 'w', 'a', 0)) {
>>>>> + av_log(s, AV_LOG_ERROR, "Unexpected SMAF chunk %08x\n",
>>>>> tag);
>>>>> + return -1;
>>>>> + }
>>>>> }
>>>>> - /* Make sure it's followed by an Awa chunk, aka wave data */
>>>>> - if ((tag & 0xffffff) != MKTAG('A', 'w', 'a', 0)) {
>>>>> - av_log(s, AV_LOG_ERROR, "Unexpected SMAF chunk %08x\n", tag);
>>>>> - return -1;
>>>>> - }
>>>>>
>> I was referring only to the 5+ and 5- I quoted. Which one of the following
>> 5 lines was actually changed beyond indentation? If none, it is a cosmetical
>> change.
>
>
> as far as I can see he moved code inside previous block. notice the closing
> brace between added and removed parts.
If he doesn't change indentation, such change would be:
> + }
>
> /* Make sure it's followed by an Awa chunk, aka wave data */
> if ((tag & 0xffffff) != MKTAG('A', 'w', 'a', 0)) {
> av_log(s, AV_LOG_ERROR, "Unexpected SMAF chunk %08x\n", tag);
> return -1;
> - }
Which is much more readable IMHO.
-Vitor
More information about the ffmpeg-devel
mailing list