[FFmpeg-devel] [PATCH]VDPAU patch for VC1 decoding, round 6

Carl Eugen Hoyos cehoyos
Wed Jan 14 00:36:09 CET 2009


Michael Niedermayer <michaelni <at> gmx.at> writes:

> > +    PIX_FMT_VDPAU_VC1_MAIN,
> > +    PIX_FMT_VDPAU_VC1_ADVANCED
> 
> Iam against pix formats per profile

It is actually just poor naming: Two different PIX_FMTs are needed, one for
CODEC_ID_VC1, one for CODEC_ID_WMV3.

I'll use PIX_FMT_VDPAU_WMV3 and PIX_FMT_VDPAU_VC1, ok?

[...]

> > +        if (v->bi_type)
> > +            render->info.vc1.picture_type = 4;
> > +        else
> > +            render->info.vc1.picture_type = 3;
> > +        break;
> [...]
> > +    case  FF_BI_TYPE:
> > +        render->info.vc1.picture_type     = 4;
> > +        break;
> > +    }
> 
> This looks redundant
> and actually, the FF_BI_TYPE looks just like a poor hack
> whichever is the correct pict_type it should not be changed
> that is if bi_type is used to identify them then FF_BI_TYPE should
> be removed from libavcodec, otherwise bi_type should be removed
> 
> and the code above is just
> if(v->bi_type) render->info.vc1.picture_type= 4
> else           render->info.vc1.picture_type= table[s->pict_type];

I will fix this and resend.

Thank you, Carl Eugen





More information about the ffmpeg-devel mailing list