[FFmpeg-devel] [PATCH] Implement sws_printVec2()

Stefano Sabatini stefano.sabatini-lala
Thu Feb 12 21:27:55 CET 2009

On date Wednesday 2009-02-11 23:48:27 +0100, Diego Biurrun encoded:
> On Wed, Feb 11, 2009 at 11:19:48PM +0100, Stefano Sabatini wrote:
> > 
> > this function has been suggested by Michael in a recent thread.
> I must admit I don't know a better name, but functions with a '2'
> suffix always strike me as horribly named.

It's standard practice in FFmpeg to rename a function with a 2 suffix,
when the original function has problems API-wise, and I don't think it
is especially ugly in this case.

Also I can't think of a better name for it, and when we will drop
sws_printVec() at the next major bump you can think of to rename this
function back to sws_printVec (not that I think that that would be a
good idea).

FFmpeg = Funny and Freak Maxi Purposeless Erotic Game

More information about the ffmpeg-devel mailing list