[FFmpeg-devel] different output in threaded code - linux vs mingw

Gianluigi Tiesi mplayer
Tue Oct 7 06:54:47 CEST 2008

On Mon, Oct 06, 2008 at 10:31:59PM -0300, Ramiro Polla wrote:
> Hi,
> On Mon, Oct 6, 2008 at 10:24 PM, Gianluigi Tiesi <mplayer at netfarm.it> wrote:
> > Hi all,
> > I'm playing with make test, and I have found a non deterministic
> > output in threaded code on mingw.
> >
> > I run:
> > ./ffmpeg_g -y -flags +bitexact -dct fastint -idct simple -sws_flags
> > +accurate_rnd+bitexact -b 500k -flags +mv4+part+aic -trellis 1 -mbd bits
> > -ps 200 -bf 2 -f image2 -vcodec pgmyuv -i tests/vsynth2/%02d.pgm -an
> > -vcodec mpeg4 -threads 2 ./tests/data/a-mpeg4-thread.avi
> I think this is just good old issue517 [0]
> It fails in the mpeg2-thread test as well, doesn't it?
> > and I get different outputs on mingw at each run, while
> > the output is always the same on linux.
> That's odd. I never tried this test on a multiple core machine on
> Windows, but I've always been able to reproduce it in Linux (and I can
> no longer test since I'm now using virtualbox with no multiple core
> virtualization).

So it's not a win32 only related? it depends by multi core ?
I'm using amd64 x2 on win32 and a single core for linux tests

The visual output of the mt encoding looks ok.


Gianluigi Tiesi <sherpya at netfarm.it>
EDP Project Leader
Netfarm S.r.l. - http://www.netfarm.it/
Free Software: http://oss.netfarm.it/

More information about the ffmpeg-devel mailing list