[FFmpeg-devel] [PATCH] RDT/Realmedia patches #2

Luca Abeni lucabe72
Thu Oct 2 15:02:02 CEST 2008

Hi Ronald,

Ronald S. Bultje wrote:
> Hi Luca,
> apparently I could do it just now, didn't take so long.

I was pretty sure about this ;-)

> On Thu, Oct 2, 2008 at 2:12 AM, Luca Abeni <lucabe72 at email.it> wrote:
>> I do not like the "RTP" part of the name. "PacketDataContext" is ok, I
>> thin. Or "PayloadContext" (since the structure contains data needed to
>> parse the payload, right?)
> $attached.

The patch looks ok. I did not test it, but I assume you did (if yes,
I think the patch can be applied - you can wait some days as usual
to give other people the possibility to comment).

> If wanted, for commit I can split into the struct renaming
> (1) and the API change in parse_packet(RTPDemuxContext,... ->
> parse_packet(PayloadContext,...

If it is possible without major troubles, and without breaking the
compilation between the two commits, it would be nice.


More information about the ffmpeg-devel mailing list