[FFmpeg-devel] [PATCH] add FFARRAY_SIZE macro
Wed Oct 1 23:10:19 CEST 2008
esOn Mon, Sep 29, 2008 at 07:04:59PM +0200, Aurelien Jacobs wrote:
> Benoit Fouet wrote:
> > hi,
> > patch to $subj attached
> That's at least the third time such a patch is proposed. It seems to be
> a quite popular request :-)
> IIRC, last time this came up, Michael was not happy with the name of
> the macro. Well, another popular name for this macro is COUNTOF().
> So maybe attached patch would be acceptable ?
iam not happy about this one either, to see why, just try to form a
english sentence with it
the size of an array (in bytes?)
the length of an array (in bytes?)
the count of arrays
what my problem is with the suggestions is just that they subtetly mean
something ambigous or wrong compared to what they actually are.
are maybe better choices
Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB
Its not that you shouldnt use gotos but rather that you should write
readable code and code with gotos often but not always is less readable
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: Digital signature
More information about the ffmpeg-devel