[FFmpeg-devel] [PATCH] Improve documentation and error reporting for the -pass option
Sun Nov 30 17:14:47 CET 2008
Stefano Sabatini wrote:
> On date Sunday 2008-11-30 08:32:02 -0500, The Wanderer encoded:
>> Stefano Sabatini wrote:
>>> Just another nitpick, "log file" or "logfile"?
>> "log file" is more correct, but then that leads to grouping issues
>> (which are already there because "two pass" is being used as an
>> adjective but isn't joined with e.g. a hyphen) which can be very
>> hard to solve.
> Check the patch attached, there is still a grouping issue but I think
> that we can go with that...
Yes, it's better (and better than I would likely have been able to do).
I see one possible way to maybe improve it further, but there are
potential problems with that too, so I'd call this good enough as far as
I would, however, probably say "that log file is used" rather than "that
log file is read". That's not worth reposting the patch over, though.
>> I take it this is in reaction to the discussion over on -user with
>> "Viaduct Productions"?
>> As a fix for that issue I'm not terribly happy with this,
>> particularly since he(?) hasn't said "yes, this would have avoided
>> confusion as far as I was concerned" or similar, but I don't have
>> anything solid to base objections on.
> And maybe he will never do some concrete proposal, but others did so
> I based this patch on it.
Unfortunately, so far as I remember, every single one of the proposals
made by other people (including me) he has rejected with the claim that
he would still have interpreted it incorrectly.
I don't see how your patch's form could be interpreted incorrectly, but
then I have a hard time seeing how the existing form could be
interpreted incorrectly either, so I'm not necessarily a good judge -
and I would rather not make a change which doesn't solve the problem.
Warning: Simply because I argue an issue does not mean I agree with any
side of it.
Secrecy is the beginning of tyranny.
More information about the ffmpeg-devel