[FFmpeg-devel] [PATCH] RDT/Realmedia patches #2

Ronald S. Bultje rsbultje
Sun Nov 23 17:16:19 CET 2008


Hi,

On Mon, Nov 17, 2008 at 5:11 PM, Michael Niedermayer <michaelni at gmx.at> wrote:
> On Mon, Nov 17, 2008 at 09:40:34AM -0500, Ronald S. Bultje wrote:
>> @@ -324,11 +325,12 @@
>>      if (!s->parse_packet)
>>          return -1;
>>
>> -    if (!buf) {
>> +    if (!buf && s->prev_stream_id != -1) {
>>          /* return the next packets, if any */
>>          timestamp= 0; ///< Should not be used if buf is NULL, but should be set to the timestamp of the packet returned....
>>          rv= s->parse_packet(s->dynamic_protocol_context,
>> -                            s->st, pkt, &timestamp, NULL, 0, flags);
>
>> +                            s->ic->streams[s->st->index + s->prev_stream_id],
>
> s->st has a poor name and lacks documentation

This patch changes the prototype of rdt_demux_context_open() so that
it takes an index integer to the first AVStream pointed to by the
RTSPStream, matching the fact that one RTSPStream (in RDT) can have
multiple contained (AV)streams.

Ronald
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: rtsp-move_st_to_idx.patch
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20081123/9ae049ff/attachment.txt>



More information about the ffmpeg-devel mailing list