[FFmpeg-devel] [PATCH] RDT/Realmedia patches #2
Tue Nov 11 20:56:28 CET 2008
On Tue, Nov 11, 2008 at 01:13:23PM -0500, Ronald S. Bultje wrote:
> On Tue, Nov 11, 2008 at 10:20 AM, Michael Niedermayer <michaelni at gmx.at> wrote:
> > audio/video is a type not a set
> > one could speak of the set of all video streams or of a subset of all video
> > streams but your text is too unclear to even guess if either or none of this
> > is meant.
> I don't know which of the two applies. In all streams I've seen so
It doesnt matter which applies so much, what matters is that the variable
where and are completely undocumented and i have absolutely no idea what
they are without "reverse engeneering" it out of the code.
no matter what you do know about the variable you are not writing it down,
its just a black box that receives a completey different and incompatible
name in each iteration of the patch.
also for example stream_id&1 == keyframe shows immedeatly that the variable
cannot be _any_ id or type of stream or set of streams. Its lowest bit is
clearly a keyframe flag. But then again this MUST be documented in the
variable name or doxy for it not found out by finding a
if(stream_id&1) keyframe=1; or something like that
> far, it's the set of all streams per type, e.g. all audio or all video
> streams. So I've renamed it to stream_type. I can call it
> stream_type_id if you prefer, since the number by itself doesn't tell
> us whether it's audio or video, it's just an id of the set of all
> audio or video streams.
either it is a stream type or an id of a stream or an id of a set of streams
or a index into a list of streams or something entirely different.
Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB
Republics decline into democracies and democracies degenerate into
despotisms. -- Aristotle
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: Digital signature
More information about the ffmpeg-devel