[FFmpeg-devel] [PATCH] Common ACELP code & G.729 [2/7] - pitch lag decoding

Diego Biurrun diego
Tue Jun 24 22:05:04 CEST 2008


On Tue, Jun 24, 2008 at 11:24:17PM +0700, Vladimir Voroshilov wrote:
> 2008/6/18 Diego Biurrun <diego at biurrun.de>:
> >
> > TTBOMK both are synonyms.  I would prefer delay, which is the more
> > common and more technical term and AFAICT it is used everywhere else.
> > Go for delay.
> 
> Done.
> I didn't touch filename, though.
> "acelp_pitch_delay" sounds too long for me
> If you wish and there are no more fixes in the file i can rename it too.

Yes, please rename it, it's just two characters more and using "delay"
everywhere and calling the file "lag" is confusing and silly.

Some more small comments are below.

> --- /dev/null
> +++ b/libavcodec/acelp_pitch_lag.c
> @@ -0,0 +1,129 @@
> +
> +    energy = ((ff_exp2(energy & 0x7fff) + 16) >> 5); // Only fraction part of (0.15) and rounding

lowercase

> --- /dev/null
> +++ b/libavcodec/acelp_pitch_lag.h
> @@ -0,0 +1,231 @@
> + *
> + * \remark The routine is used in G.729 @8k, AMR @10.2k, AMR @7.95k, AMR @7.4k for the second subframe.

That line is looong.

> + * The routine implements equations 69, 66 and 71 of the G.729 specification (3.9.1)

.

> + *    M    - ma prediction order

ma?

> + *    Predicted fixed codebook gain gc_p is computed using from
> + *    known as predicted energies:


"The predicted..."

But this is very confusing.  What are you trying to say by "using from
known as"?

> + *      E is calculated as following (3.9.1 Equation 66 of G.729)

.

Diego




More information about the ffmpeg-devel mailing list