[FFmpeg-devel] Realmedia patch
Sun Aug 31 23:18:02 CEST 2008
Ronald S. Bultje wrote:
>>> + rdt_data *rdt = av_mallocz(sizeof(rdt_data) + FF_INPUT_BUFFER_PADDING_SIZE);
>> why "+ FF_INPUT_BUFFER_PADDING_SIZE" here?
> Not at all stupid, it's for the later frame-parsing, which adds a
> reading buffer at the end of rdt_data. If you wish (I'm sure you do
> :-) ), I can remove it from this patch and re-add it in the later one.
I think the best solution would be to remove this
"+ FF_INPUT_BUFFER_PADDING_SIZE" and change the
+ char buffer[RTP_MAX_PACKET_LENGTH]; // keep last please
line of the following patch in
+ char buffer[RTP_MAX_PACKET_LENGTH + FF_INPUT_BUFFER_PADDING_SIZE]; // keep last please
(this field is the reading buffer you are mentioning, right?).
I think this is also more correct, because the compiler can
theoretically reorder the structure's fields (I think).
More information about the ffmpeg-devel