[FFmpeg-devel] Realmedia patch
Wed Aug 27 08:53:37 CEST 2008
Ronald S. Bultje wrote:
>> Again, here I'd like to have something more generic. Instead
>> of a "is_real_datatype" variable, we can have some kind of
>> "rtsp_flavour" enum (feel free to find a better name), which
>> can currently assume only the "STANDARD_RTSP" and "REAL_RTSP"
>> values (but someone can extend it in the future).
> So, I'm sort of in doubt here. I can go two ways for this sort of stuff.
> 1: simply add the enum
> 2: add the enum plus a set of vfuncs (similar to the
> RTPDynamicProtocol function pointers)
> Which one would you prefer?
I _personally_ think that 1) would be ok (after all, I've not
been the one proposing to use RTPDynamicProtocol and function
pointers for this stuff ;-).
I suspect the code needs a little bit of refactoring, but then
the enum approach can be implemented without too much complexity.
I think the best way to go is to
- first fix rtsp.c to make it more generic and to remove the
"RTSP ===> RTP" assumption
- after that, introduce RDT support with a second patch.
And I believe the most difficult part is doing the first step
in a clean way.
More information about the ffmpeg-devel