[FFmpeg-devel] [PATCH] Fill unspecified AVCodec long_name fields

Stefano Sabatini stefano.sabatini-lala
Tue Apr 29 00:12:29 CEST 2008


On date Monday 2008-04-28 12:14:47 +0200, Diego Biurrun encoded:
> On Mon, Apr 28, 2008 at 09:08:54AM +0200, Stefano Sabatini wrote:
> > On date Monday 2008-04-28 00:40:32 +0200, Diego Biurrun encoded:
> > > 
> > > Next bunch applied, could you please update again?
> > 
> > Yes, new patch attached.
> 
> Another part applied, comments below.
> 
> > --- libavcodec/bmp.c	(revision 13009)
> > +++ libavcodec/bmp.c	(working copy)
> > @@ -257,5 +257,6 @@
> >      bmp_decode_end,
> > -    bmp_decode_frame
> > +    bmp_decode_frame,
> > +    .long_name = "BMP image",
> 
> Hmmmm

Well I'm somehow unsatisfied with it too, but I can't find nothing
better, maybe something like:
Microsoft BMP (BitMaP) image
?

> > --- libavcodec/dv.c	(revision 13009)
> > +++ libavcodec/dv.c	(working copy)
> > @@ -1240,6 +1240,7 @@
> >      .pix_fmts = (enum PixelFormat[]) {PIX_FMT_YUV411P, PIX_FMT_YUV422P, PIX_FMT_YUV420P, -1},
> > +    .long_name = "DV",
> 
> I think DV is the short form of "Digital Video".

What about "DV (Digital Video)"?

> > --- libavcodec/flicvideo.c	(revision 13009)
> > +++ libavcodec/flicvideo.c	(working copy)
> > @@ -749,5 +749,6 @@
> > -    NULL
> > +    NULL,
> > +    .long_name = "Autodesk Animator Flic (.fli/.flc) video",
> 
> I would say leave out the filename extensions, same below.

OK here and there.

> > --- libavcodec/h263dec.c	(revision 13009)
> > +++ libavcodec/h263dec.c	(working copy)
> > @@ -748,6 +750,7 @@
> >      CODEC_CAP_DRAW_HORIZ_BAND | CODEC_CAP_DR1,
> > +    .long_name="Microsoft variant version 1 MPEG-4 part 2",
>
> Is this some sort of official name?  Otherwise I would say
> "MPEG-4 part 2 Microsoft variant version 1".

OK.
 
> > --- libavcodec/h264.c	(revision 13009)
> > +++ libavcodec/h264.c	(working copy)
> > @@ -8087,6 +8087,7 @@
> >      .flush= flush_dpb,
> > +    .long_name = "H.264 / AVC / MPEG-4 part 10",
> 
> I think it is MPEG-4 AVC.

As Loren also said, I think these names are more or less equivalent,
AVC is often used without any reference to MPEG-4, but I don't know do
as you prefer.

> > --- libavcodec/huffyuv.c	(revision 13009)
> > +++ libavcodec/huffyuv.c	(working copy)
> > @@ -1444,7 +1444,8 @@
> > -    NULL
> > +    NULL,
> > +    .long_name = "Huffyuv",
> 
> The multimedia wiki calls this HuffYUV :)

I changed it from "HuffYUV" to "Huffyuv" after Loren suggested to use:
"FFmpeg's Variant of Huffyuv", also the link to the official web page:
http://neuron2.net/www.math.berkeley.edu/benrg/huffyuv.html
use consistently Huffyuv instead of HuffYUV, while according to
wikipedia both version are correct, so I'd suggest to leave it as it
is or maybe to change it to:
Huffyuv / HuffYUV


> > --- libavcodec/libgsm.c	(revision 13009)
> > +++ libavcodec/libgsm.c	(working copy)
> > @@ -106,6 +106,7 @@
> >      libgsm_close,
> > +    .long_name = "libgsm GSM (Global System for Mobile Communications)",
> 
> I would leave out the explanation in parentheses.

OK.

> > --- libavcodec/libx264.c	(revision 13009)
> > +++ libavcodec/libx264.c	(working copy)
> > @@ -296,5 +296,6 @@
> > -    .pix_fmts = (enum PixelFormat[]) { PIX_FMT_YUV420P, -1 }
> > +    .pix_fmts = (enum PixelFormat[]) { PIX_FMT_YUV420P, -1 },
> > +    .long_name = "libx264 H.264 / AVC / MPEG-4 part 10",
> 
> see above
> 
> > --- libavcodec/libxvidff.c	(revision 13009)
> > +++ libavcodec/libxvidff.c	(working copy)
> > @@ -774,4 +774,5 @@
> >      .pix_fmts= (enum PixelFormat[]){PIX_FMT_YUV420P, -1},
> > +    .long_name= "libxvidcore MPEG-4 part 2",
> 
> Maybe add MPEG-4 ASP here as well?
> 
> > --- libavcodec/ljpegenc.c	(revision 13009)
> > +++ libavcodec/ljpegenc.c	(working copy)
> > @@ -194,4 +194,5 @@
> >      MPV_encode_end,
> > +    .long_name = "Lossless JPEG",
> 
> lossless

It was the first version, then Kostya commented:
> > +    .long_name = "lossless JPEG",
> >  };
>
> why lowercase?

on Google I found both versions, with a slightly predominance of the
upcased version, this is consistent with the fact that the "Lossless"
is considered part of the name, and not a simple adjective (well it is
a rather fuzzy motivation), do as you prefer.

> > --- libavcodec/mjpegbdec.c	(revision 13009)
> > +++ libavcodec/mjpegbdec.c	(working copy)
> > @@ -145,5 +145,6 @@
> > +    NULL,
> > +    .long_name = "Apple MJPEG-B",
> 
> This is Apple-specific?

>From Wikipedia:

|For Quicktime formats, Apple have defined two types of coding: MJPEG-A
|and MJPEG-B. MJPEG-B no longer retains valid JPEG Interchange Files
|within it, hence it is not possible to take a frame into a JPEG file
|without slightly modifying the headers.

So I'd say yes it is something Apple-specific.

> > --- libavcodec/mpeg12.c	(revision 13009)
> > +++ libavcodec/mpeg12.c	(working copy)
> > @@ -2442,6 +2442,7 @@
> >      .flush= ff_mpeg_flush,
> > +    .long_name= "MPEG-1 video",
> 
> I would say s/video//, same below.

I think "MPEG-1 video" is better than "MPEG-1 alone", this is why MPEG-1
is a standard which covers many parts, the same for MPEG-2 video.

> > --- libavcodec/mpegvideo_enc.c	(revision 13009)
> > +++ libavcodec/mpegvideo_enc.c	(working copy)
> > @@ -3800,6 +3805,7 @@
> >      .capabilities= CODEC_CAP_DELAY,
> > +    .long_name= "MPEG-4 part 2",
> > @@ -3811,6 +3817,7 @@
> >      .pix_fmts= (enum PixelFormat[]){PIX_FMT_YUV420P, -1},
> > +    .long_name= "Microsoft variant version 1 MPEG-4 part 2",
> > @@ -3822,6 +3829,7 @@
> >      .pix_fmts= (enum PixelFormat[]){PIX_FMT_YUV420P, -1},
> > +    .long_name= "Microsoft variant version 2 MPEG-4 part 2",
> > @@ -3833,6 +3841,7 @@
> >      .pix_fmts= (enum PixelFormat[]){PIX_FMT_YUV420P, -1},
> > +    .long_name= "Microsoft variant version 3 MPEG-4 part 2",
> 
> see above
> 
> > --- libavcodec/msrle.c	(revision 13009)
> > +++ libavcodec/msrle.c	(working copy)
> > @@ -304,4 +304,5 @@
> >      CODEC_CAP_DR1,
> > +    .long_name= "Microsoft RLE Video",
> 
> I would say s/video//.

OK.

> > --- libavcodec/sonic.c	(revision 13009)
> > +++ libavcodec/sonic.c	(working copy)
> > @@ -957,6 +958,7 @@
> >      NULL,
> > +    .long_name = "Sonic Lossless",
> 
> lossless
> 
> > --- libavcodec/tiertexseqv.c	(revision 13009)
> > +++ libavcodec/tiertexseqv.c	(working copy)
> > @@ -227,4 +227,5 @@
> >      CODEC_CAP_DR1,
> > +    .long_name = "Tiertex Limited SEQ Video",
> 
> Hmm, the multimedia wiki lists this as simply "SEQ".

Hmmm.. sorry for nitpicking but I prefer leave it as is(but downcasing
the "Video" part), I prefer to give more informations rather than
less, again no strong opinion.

> > --- libavcodec/truemotion1.c	(revision 13009)
> > +++ libavcodec/truemotion1.c	(working copy)
> > @@ -899,4 +899,5 @@
> >      CODEC_CAP_DR1,
> > +    .long_name = "Duck TrueMotion 1.0",
> > --- libavcodec/truemotion2.c	(revision 13009)
> > +++ libavcodec/truemotion2.c	(working copy)
> > @@ -887,4 +887,5 @@
> >      CODEC_CAP_DR1,
> > +    .long_name = "Duck/On2 TrueMotion 2.0",
> 
> Duck or Duck/On2?


mmmh... your're forcing me to investigate, all right since I like this
kind of investigations ;-)... 

I think it is more correct Duck here, as far as I can understand
TrueMotion 2.0 has been developed by the The Duck Company before they
changed name to/were acquired by On2.

> > --- libavcodec/tta.c	(revision 13009)
> > +++ libavcodec/tta.c	(working copy)
> > @@ -443,4 +443,5 @@
> >      tta_decode_frame,
> > +    .long_name = "TTA (The Lossless True Audio)",
> 
> I think this is just "True Audio".

OK.

> > --- libavcodec/vmnc.c	(revision 13009)
> > +++ libavcodec/vmnc.c	(working copy)
> > @@ -517,6 +517,7 @@
> >      decode_end,
> > -    decode_frame
> > +    decode_frame,
> > +    .long_name = "VMware Screen Codec",
> 
> The multimedia Wiki calls this VMware Video.

When in doubt use both forms ;-), for example:
VMware Screen Codec / VMware Video

the first one seems more reasonable to me (VMware screeN Codec), and
is already used by xine (for example check:
http://xine-lib.alioth.debian.org/patches-1.2/extra_codecs
). 
 
> > --- libavcodec/vqavideo.c	(revision 13009)
> > +++ libavcodec/vqavideo.c	(working copy)
> > @@ -616,4 +616,5 @@
> >      CODEC_CAP_DR1,
> > +    .long_name = "Westwood Studios VQA Video",
> 
> The multimedia wiki says: "VQA stands for Vector Quantized Animation and
> is a FMV format used in a number of computer games by Westwood Studios."

What about:
"Westwood Studios VQA (Vector Quantized Animation) video"
?

Sorry for the nitpicking, I'm putting in the attached patch my
preferred choices, I leave the final choice to you/other codec
maintainers.

Best regards.
-- 
FFmpeg = Fiendish Frenzy Magical Proud ExchanGer
-------------- next part --------------
A non-text attachment was scrubbed...
Name: add-missing-long-names-07.patch
Type: text/x-diff
Size: 17090 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20080429/9522021c/attachment.patch>



More information about the ffmpeg-devel mailing list