[FFmpeg-devel] Mpeg4 audio in TS

Vamsi Krishna vamsi.buragapu
Fri Apr 18 08:24:38 CEST 2008


 I am working on Mpeg-4 TS with HEAAC audio in LATM transport syntax (
14496-3 ).

 I tried extracting the mpeg-4 ES from the TS.  And I am unable decode the
ES using the ISO reference software.  I tried using both decoders - mp4mcdec
and mp4audVM_rewrite.

 *Mp4mcdec *? results in

*" ADTS Syncword error "                                    *

*Warning: missing ADTS-syncword... trying RAW*

*Warning: ICS - reserved bit is not set to 0           *

? this doesnot support LATM audio syntax.


 *Mp4audVM_rewrite* ? results in the following errors:

 *mp4audec: WARNING: BsOpenFileRead: magic string error (found "V?= ", need

*StreamFile:openRead(LATM): error opening bit stream for reading*

*mp4audec: WARNING: BsOpenFileRead: magic string error (found "V?= ", need

*mp4audec: WARNING: StreamFile:openRead: can not determine file format*

*mp4audec: WARNING: error decoding audio file xyz.mp4*

My stream starts with  0x5E 0x61 ?.

 I could not find the syncword 0x2B7 at the beginning of my stream.

can you please help me out to decode the LATM audio stream.

And it ll also be helpful, if you can provide some information on LATM

Thank you in advance.


More information about the ffmpeg-devel mailing list