[FFmpeg-devel] [PATCH] ISS-Funcom Demuxer

Reimar Döffinger Reimar.Doeffinger
Sun Apr 6 01:02:02 CEST 2008

On Sat, Apr 05, 2008 at 11:47:10PM +0100, Balatoni Denes wrote:
> Hi!
> While we are nitpicking ...
> Saturday 05 April 2008 21:41-kor Reimar D?ffinger ezt ?rta:
> > but if you want to keep the current way, a name like last_pts seems
> > better to me, audio_frame_count seems bad to me, because
> > 1) the term audio "frame" is quite often use to mean a whole decoding
> > block not just one sample (for each channel)
> > 2) "count" to me sounds like the total number, not just the amount read
> > so far
> To me "count" means it is counting something - and it could absolutely be 
> counting the amount read so far imho.

Well, if it was "counter", but "count" has more a meaning of "total

> Actually "nr" conveys total number to 
> me more so than count.

I agree it is no good either, current_sample/last_sample/last_pts is
probably better.

> ps: thanks for bringing up this very important point Reimar!

Actually I was only bringing it up because upon reading the code the
first time I immediately assumed it would be the total number of audio
frames and was a bit confused when the code did not match the
And anyway, I always mention anything that comes to mind when I look at
a patch, better get used to it (and just say if you don't consider
something worth changing).

Reimar D?ffinger

More information about the ffmpeg-devel mailing list