[FFmpeg-devel] Issue with ffmpeg mp3 decoder on ARM11

Alexy galahad
Mon Jul 16 20:28:55 CEST 2007


 I am trying to use ffmpeg mp3 decoder on an ARM processor. When
avcodec_decode_audio2 is called for decode, the decoded buffer is filled
with only zeroes. When i checked the same version of ffmpeg on a linux pc
the decoded output does not have this problem.

This is the configuration that i use.

FFmpeg version SVN-r9144
libavutil version: 49.4.0
libavcodec version: 51.40.4
libavformat version: 51.12.1
configuration options: ./configure --cross-compile
--cross-prefix=/usr/local/arm/3.3.2/bin/arm-linux- --arch=armv4l
--enable-shared --disable-static --prefix=/work/omap2430/rootfs26/usr/local/
--enable-memalign-hack --libdir=/usr/local/arm/3.3.2/lib/
gcc version: arm gcc 3.3.2

 I have also tried disabling optimization and also giving arch= . The output
buffer becomes filled with an occasional 0xFFFF, which is still not the
correct output.

 Has anyone else faced the same problem? Could you please give me some
pointers about this? I tried searching through the archives, but i could not
find any help.



More information about the ffmpeg-devel mailing list