[FFmpeg-devel] Compiling FFMPEG in /usr/impulsedev directory

Eliot Simcoe ibruiseeasily84
Mon Jul 2 15:49:02 CEST 2007


This probably just shows my ignorance of the makefile
system, but how can I tell ffmpeg to compile into and
use libraries installed in the /usr/impulsedev

I created /usr/impulsedev because I will be linking
against ffmpeg's libraries in a piece of my software
and this will isolate the libraries and programs from
the rest of the system. The only problem is I can't
figure out how to compile ffmpeg to use libraries in
the /usr/impulsedev/lib directory.

Any thoughts? I tried passing --prefix=/usr/impulsedev
to ./configure but that didn't fix the linking issues.
Configure complains that the support libraries cannot
be found. The above worked for each of the
dependencies (faac, lame, libgsm, etc...), however.

Thanks for your time,

Take the Internet to Go: Yahoo!Go puts the Internet in your pocket: mail, news, photos & more. 

More information about the ffmpeg-devel mailing list