[Ffmpeg-devel] [PATCH] always_inline -> FFMPEG_ALWAYS_INLINE

Rich Felker dalias
Thu Mar 16 08:52:16 CET 2006

On Thu, Mar 16, 2006 at 09:28:57AM +0200, Matti Hamalainen wrote:
> Changes occurences of always_inline to FFMPEG_ALWAYS_INLINE,
> which will be #defined to appropriate values in common.h etc.
> according to gcc version. configure is patched to #define CONFIG_SMALL
> if inlining is not desired, in which case FFMPEG_ALWAYS_INLINE is
> defined to nothing.
> This remedies some problems with different versions of gcc handling
> inline/always_inline etc. Someone wanted a change like this some time ago 
> and I made & submitted this patch, but nobody reacted on it.
> I now updated the patch to apply cleanly to latest CVS, please someone 
> comment/commit/reject, whatever will be the case.

IMO this change is nonsense. Just #define always_inline to whatever it
needs to be (even better would be to just use inline and redefine it
for broken gcc versions that refuse to honor it.. :). I don't see how
changing the name to something new and ugly makes the situation any


More information about the ffmpeg-devel mailing list