[Ffmpeg-devel] [PATCH] rename CONFIG_WIN32 to CONFIG_MINGW/__MINGW32__
Måns Rullgård
mru
Mon Jul 10 20:39:43 CEST 2006
Diego Biurrun <diego at biurrun.de> writes:
> We currently have a confusing way to specify MinGW, we call it
> CONFIG_WIN32 while this name is usually reserved for something that
> encompasses both MinGW and Cygwin.
>
> This patch renames CONFIG_WIN32 to __MINGW__ within the source files and
> to CONFIG_MINGW within the build system along with cleaning up some of
> the confusion that this naming scheme seems to have entailed in the
> past.
>
> OK to commit?
Fine by me in general, assuming the compiler defines __MINGW32__.
Just a couple of minor things:
> Index: libavutil/common.h
> ===================================================================
> --- libavutil/common.h (revision 5705)
> +++ libavutil/common.h (working copy)
> @@ -292,7 +292,7 @@
> # include <assert.h>
>
> /* dprintf macros */
> -# if defined(CONFIG_WIN32) && !defined(__MINGW32__) && !defined(__CYGWIN__)
> +# if defined(CONFIG_WIN32)
CONFIG_WIN32 isn't ever defined with your change, right? I think this
is a remnant of the days long gone when ffmpeg could be built with
msvc. Get rid of the #ifdef entirely.
> -#if defined(CONFIG_WIN32) || defined(CONFIG_OS2) || defined(__CYGWIN__)
> +#if defined(_MINGW32__) || defined(CONFIG_OS2) || defined(__CYGWIN__)
Typo ----------^
--
M?ns Rullg?rd
mru at inprovide.com
More information about the ffmpeg-devel
mailing list