[Ffmpeg-devel] Still Trying to Compile on Mac OS X

Guillaume POIRIER poirierg
Sun Jul 2 11:29:14 CEST 2006


On 7/2/06, Anthony N. Frasso <afrasso at yahoo.com> wrote:
> I think I'm on what... round 6? :-P
> Well, I hadn't tried compiling in a couple of weeks,
> so I thought I'd try again.  I redownloaded the source
> code and tried to compile... but that didn't work.  It
> seems the configure script can't find Xvid.  Just to
> make sure, I reinstalled Xvid, but I still get the
> same problem.
> Here is the console log:
> Anthony-Frassos-Computer:/Users/tony/Software/ffmpeg
> root# ./configure --enable-mp3lame --enable-xvid
> --enable-x264 --enable-a52 --enable-gpl
> ERROR: XviD not found
> If you think configure made a mistake, make sure you
> are using the latest
> version from SVN.  If the latest version fails, report
> the problem to the
> ffmpeg-devel at mplayerhq.hu mailing list or IRC #ffmpeg
> on irc.freenode.net.
> Include the log file "config.err" produced by
> configure as this will help
> solving the problem.
> And I've attached the config.err file.

I'm in a hurry, so I can't have a look at the attachement for the
relevant information. I just would like to advise you to have a look
at MPlayer's doc: it may contain some relevant information to help
you. (MPlayer and FFmpeg have a build system that is quite similar)

Also, I advise you to make sure that you ran "ranlib" on your newly
installed xvid. It may be your problem...

"If God had wanted us to vote, he would have given us candidates."
  - Jay Leno

More information about the ffmpeg-devel mailing list