[Ffmpeg-devel] DVR-MS bug (MP2 decoding)

Steve Lhomme steve.lhomme
Tue Apr 25 14:10:17 CEST 2006

Michael Niedermayer wrote:
>>> I get the source width/height from AVCodecContext* catched as this:
>>> video_codec = avctx->streams[vidTrackId]->codec;
>> Thanks for that.
>>>>> So I assume it's MP2 and not AC3.
>>>> You're right, I looked at it in GraphEdit and on my machine it chooses
>>>> my InterVideo audio decoder for this file rather than the regular MPEG
>>>> Audio Decoder. The properties dialog for the Intervideo decoder calim
>>>> it is '2 speaker mode, Dolby Sound compatible (as opposed to
>>>> stereo/mono). It says the format is MPEG2 and the attributes are
>>>> 16bit/48k/1ch. I wonder what is different about this audio stream that
>>>> causes it to pick the Intervideo decoder - maybe the 'dolby' setting?
>>> All I know is that it's not AC3. DScaler has an input type
>>> MEDIATYPE_DVD_ENCRYPTED_PACK instead of MEDIATYPE_Audio, that could be
>>> the difference.
>> I'm afraid I've got no more ideas about this. I looked at what the
>> code was doing and the demuxer reports it as an mp2 stream which is
>> presumably correct. Then the mp3 lib code makes a call to 'read_frame'
>> which repeatedly calls 'decode_header' to try to find a valid header
>> without success. libmad.a also fails in that it plays some strange
>> noises instead of the real audio stream.
> hmm, what happens if you dump the audio stream into a file and try to
> play that with mplayer or ffmpeg?

I tried:
ffmpeg -i /C/test/DivX/today.dvr-ms -vcodec copy -an dvr-ms.m2v

And got a file doesn't doesn't play.

Then I tried:
ffmpeg -i /C/test/DivX/today.dvr-ms -acodec copy -vn dvr-ms.mp2

And got an empty file.

> and if that doesnt work, maybe post a few kb of that audio stream maybe
> someone can spot something by looking at it ....

Is my command-line correct to extract audio from the source file ?


robUx4 on blog <http://robux4.blogspot.com/>

More information about the ffmpeg-devel mailing list