[Ffmpeg-devel] ffmpeg Video containing sound but No picture - Logitech QC IM with SPCA5xx

guangzhou tan guangzhoutan
Tue Apr 25 05:59:40 CEST 2006

Hi all,

This happens when I use:-
1. a Logitech Quickcam IM (Vendor/device ID= 046d:08a6)
2. the SPCA5XX driver from mxhaard
3. ffmpeg to grab a video.

ffmpeg always writes a file which contains sound but no video. ( It seems 
I'm the only person with such a problem. It might be the webcam at fault, I 

Then I accidentally found that if I run streamer, then follow by ffmpeg, 
then ffmpeg will work (just ONCE) and outputs a file with both sound and 

But subsequently the problem is back - ffmpeg always writes a file which 
contains sound but no video... until the next time I run streamer again.

It seems streamer opens up something which enables ffmpeg to work. But once 
ffmpeg is run, that something is closed again (by ffmpeg).

BTW, the streamer command line I used:
#> streamer -q -c /dev/video0 -f rgb24 -r 3 -t 00:00:05 -o outfile.avi

So where does the problem lie? ffmpeg or spca5xx driver?

I am inclined to suspect a part of spca5xx which relates to Logitach 
Quickcam IM may need a tweak.

I thank mxhaard for the wonderful spca5xx. Xawtv and streamer work. It'd be 
wonderful if ffmpeg also works ( for Logitech QC IM webcam, of course). 
Otherwise whom am I to blame? Perhaps buy more webcams just to find out if 
such a problem does not occur for at least one of them.


>From: "guangzhou tan" <guangzhoutan at hotmail.com>
>Reply-To: FFMpeg development discussions and patches 
><ffmpeg-devel at mplayerhq.hu>
>To: ffmpeg-devel at mplayerhq.hu
>CC: guangzhoutan at hotmail.com
>Subject: [Ffmpeg-devel] ffmpeg - Video containing sound but No picture
>Date: Mon, 17 Apr 2006 22:01:29 +1000
>My problem as follows:
>Irregardless of which video codec I specify, all that I get is a video clip 
>containing sound but no picture.
>As an example, I used this command line:-
>#> ffmpeg -vd /dev/video0 -vcodec msmpeg4v2 -r 10 -s 320x240 -t 3 test.avi
>The output file 'test.avi' is attached. This 3-second video file size is 
>merely 40492 bytes, which seems too little.
>I have tried many video codecs ( with the -vcodec option ) available in 
>libavcodec-0.4.9-pre1.so. The problem is the same - Blank video screen with 
>no picture.
>I suspect the problem lies in ffmpeg for these reasons:-
>1. Xawtv works well
>2. Streamer also works well ( It produced a good AVI file of 3456608 bytes 
>for a 3-second video shot )
>I tried all these on a freshly-built Red Hat Linux 7.3 computer, installed 
>RPMs required by ffmpeg, then installed ffmpeg ( Version 0.4.9-pre1, build 
>4730 )
>My webcam is Logitech Quickcam IM ( Vendor/device ID= 044d:08a6)
>I'd appreciate your help very much.
>realestate.com.au: the biggest address in property   

Read, write and reply to Hotmail on your mobile. Find out more. 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: test.avi
Type: video/avi
Size: 40492 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20060425/ad05f87f/attachment.bin>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: text4.txt
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20060425/ad05f87f/attachment.txt>

More information about the ffmpeg-devel mailing list