[Ffmpeg-devel] ffmpeg - Video containing sound but No picture

guangzhou tan guangzhoutan
Mon Apr 17 14:01:29 CEST 2006

My problem as follows:

Irregardless of which video codec I specify, all that I get is a video clip 
containing sound but no picture.

As an example, I used this command line:-

#> ffmpeg -vd /dev/video0 -vcodec msmpeg4v2 -r 10 -s 320x240 -t 3 test.avi

The output file 'test.avi' is attached. This 3-second video file size is 
merely 40492 bytes, which seems too little.

I have tried many video codecs ( with the -vcodec option ) available in 
libavcodec-0.4.9-pre1.so. The problem is the same - Blank video screen with 
no picture.

I suspect the problem lies in ffmpeg for these reasons:-
1. Xawtv works well
2. Streamer also works well ( It produced a good AVI file of 3456608 bytes 
for a 3-second video shot )

I tried all these on a freshly-built Red Hat Linux 7.3 computer, installed 
RPMs required by ffmpeg, then installed ffmpeg ( Version 0.4.9-pre1, build 
4730 )

My webcam is Logitech Quickcam IM ( Vendor/device ID= 044d:08a6)

I'd appreciate your help very much.


realestate.com.au: the biggest address in property   
-------------- next part --------------
A non-text attachment was scrubbed...
Name: test.avi
Type: video/avi
Size: 40492 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20060417/ab006e3c/attachment.bin>

More information about the ffmpeg-devel mailing list