[Ffmpeg-devel] Re: Intel IPP

g. the_ether
Tue Nov 15 17:15:46 CET 2005

Tomas Christiansson <tomas.christiansson <at> gasoptics.com> writes:
> Hi, 
> Yes, we tried this (for MPEG2 decompression) last week using IPP 4.0
> (Linux) and  managed to get an 8-9% speedup of the decompression (gcc
> 3.3.4).

Thanks for your quick reply. 

What CPU was that on?

> Hopefully we'll be able to get more speedup when we move up to
> IPP version 5.0. Below, you'll find patches (for
> 'libavcodec/i386/dsputil_mmx.c' and 'configure') from our tests..
> What kind of linking are you using? Shared libraries or static? Which
> IPP-version are you using?

I'm using v5.0 (or at least, I'm trying to).

I'm trying to use shared at the moment. I didn't get any static libs 
presumably because I simply downloaded the trial version.

In the makefile of libavcodec I simply added -LIPP_PATH -lippi -lippcore but I 
keep on getting

"In function `dsputil_init_mmx':
dsputil_mmx.c:2608: undefined reference to `ippiDCT8x8Fwd_16s_C1I at 4'
collect2: ld returned 1 exit status"

I'm not sure what the "I at 4" suffix refers to, I simply tried to use 

I used MinGW and the Windows version of IPP.



More information about the ffmpeg-devel mailing list