[Ffmpeg-devel] [PATCH] Attempt to fix vb_strategy

Alexander Strasser eclipse7
Sat May 21 10:05:29 CEST 2005


Zoltan Hidvegi wrote:
> Index: libavcodec/mpegvideo.c
> ===================================================================
> RCS file: /cvsroot/ffmpeg/ffmpeg/libavcodec/mpegvideo.c,v
> retrieving revision 1.483
> diff -u -r1.483 mpegvideo.c
> --- libavcodec/mpegvideo.c	13 May 2005 21:04:15 -0000	1.483
> +++ libavcodec/mpegvideo.c	20 May 2005 21:37:17 -0000
> @@ -2201,7 +2201,7 @@
>                                                 s->input_picture[i-1]->data[0], s->linesize) + 1;
>                      }
>                  }
> -                for(i=0; i<s->max_b_frames; i++){
> +                for(i=1; i<s->max_b_frames+1; i++){
>                      if(s->input_picture[i]==NULL || s->input_picture[i]->b_frame_score - 1 > s->mb_num/40) break;
>                  }

  Not that i know anything about this code, but in case it gets changed
wouldn't it be more readable to use <= instead of adding +1 ?
Not that it was very important, just a suggestion...

  Alex (beastd)





More information about the ffmpeg-devel mailing list