[Ffmpeg-devel] ffmpeg mp4 demuxer doesnt handle 64bit

François Revol revol
Fri Dec 30 19:32:12 CET 2005

I tried to fix it but I don't know if it works as I don't have any test 
file with version1 mdhd that I know of.

plese cvs up and test.

> i have tried uploaded a file showing this to the mplayer ftp 
> (incoming) but
> access was denied

It's not available yet.

>    type mdia
>     type mdhd
>      version = 1 (0x01)
>      flags = 0 (0x000000)
>      creationTime = 3218293987 (0x00000000bfd344e3)
>      modificationTime = 3218295051 (0x00000000bfd3490b)
>      timeScale = 15712911 (0x00efc28f)

So is it 32 or 64 bits here ??

>      duration = 4525654016 (0x000000010dc00000)
>      language = 21956 (0x55c4)

That doesn't look like a valid language code (< 138, though the table I 
have is partial)

I also added language code handling, but I still have to find a file 
with a 
non-english tag.
There is a helper func already to do the reverse in movenc.c


More information about the ffmpeg-devel mailing list