[Ffmpeg-devel] Bug in snow revision 1.50 - broken lossless mode

D Richard Felker III dalias
Wed Apr 13 21:26:10 CEST 2005

On Wed, Apr 13, 2005 at 12:13:53PM +0200, Michael Niedermayer wrote:
> Hi
> On Wednesday 13 April 2005 06:03, Yartrebo wrote:
> > Michael, those rescaled IDWT coefficients (revision 1.50) appear to have
> > broken lossless mode quite bad. It's all fuzzy now and is similar in
> > quality to quant=10 or 20. It happens for all inputs I've tried.
> the regression tests worked yesterday and they do test lossless with the 5/3 
> wavelet
> the 9/7 wavelet is with the scaling merged not bijective with fixed point 
> numbers, its bijective if rational or real numbers are used, but as the 5/3 
> wavelet is superior for lossless (at least it was in my tests) thats really 
> irrelevant
> but then again, dont hesitate to look at the lifting steps for the 9/7 
> wavelet, maybe you can come up with a better solution so that this 
> dissadvantage can be avoided

is the problem just that we have too few bits? because fracbits count
certainly be increased... i.e. we never seem to use more than 24 bits
or so out of the 32...


More information about the ffmpeg-devel mailing list