[Ffmpeg-devel] Bug in snow revision 1.50 - broken lossless mode

Yartrebo yartrebo
Wed Apr 13 20:53:34 CEST 2005

On Wed, 2005-04-13 at 12:13 +0200, Michael Niedermayer wrote:
> Hi
> On Wednesday 13 April 2005 06:03, Yartrebo wrote:
> > Michael, those rescaled IDWT coefficients (revision 1.50) appear to have
> > broken lossless mode quite bad. It's all fuzzy now and is similar in
> > quality to quant=10 or 20. It happens for all inputs I've tried.
> the regression tests worked yesterday and they do test lossless with the 5/3 
> wavelet
> the 9/7 wavelet is with the scaling merged not bijective with fixed point 
> numbers, its bijective if rational or real numbers are used, but as the 5/3 
> wavelet is superior for lossless (at least it was in my tests) thats really 
> irrelevant
> but then again, dont hesitate to look at the lifting steps for the 9/7 
> wavelet, maybe you can come up with a better solution so that this 
> dissadvantage can be avoided
> [...]
I've got another idea too ... writing either a brute force, a hill
climbing, or a genetic algorithm (depending just how big the problem
space is and what rules I can figure out by hand) to find the simplest
lift implementation for a given set of inputs and outputs (fastest to
compute, for inputs limited to a certain # of bits, and operations
bounded to 32 bit intermediates).

Maybe the algorithm could even find a better implementation that the
current one.

Any comments on this approach?


More information about the ffmpeg-devel mailing list