[Ffmpeg-devel] Bug in snow revision 1.50 - broken lossless mode

Yartrebo yartrebo
Wed Apr 13 14:53:29 CEST 2005

On Wed, 2005-04-13 at 12:13 +0200, Michael Niedermayer wrote:
> Hi
> On Wednesday 13 April 2005 06:03, Yartrebo wrote:
> > Michael, those rescaled IDWT coefficients (revision 1.50) appear to have
> > broken lossless mode quite bad. It's all fuzzy now and is similar in
> > quality to quant=10 or 20. It happens for all inputs I've tried.
> the regression tests worked yesterday and they do test lossless with the 5/3 
> wavelet
> the 9/7 wavelet is with the scaling merged not bijective with fixed point 
> numbers, its bijective if rational or real numbers are used, but as the 5/3 
> wavelet is superior for lossless (at least it was in my tests) thats really 
> irrelevant
> but then again, dont hesitate to look at the lifting steps for the 9/7 
> wavelet, maybe you can come up with a better solution so that this 
> dissadvantage can be avoided
> [...]
In that case, it would be nice to make 5/3 the default for lossless. It
really doesn't make snow look good to have the default mode (9/7,
lossless) look so ugly.


More information about the ffmpeg-devel mailing list