[FFmpeg-cvslog] avformat/dashdec: rename variable name for more readable
Steven Liu
git at videolan.org
Thu Feb 4 04:30:59 EET 2021
ffmpeg | branch: master | Steven Liu <liuqi05 at kuaishou.com> | Mon Jan 18 14:22:08 2021 +0800| [29ef547c16cdfc6d4dfe71400e17cee13c9ff399] | committer: Steven Liu
avformat/dashdec: rename variable name for more readable
Rename is_init_section_common_audio to is_init_section_common_subtitle
for is_common_init_section_exist(c->subtitles, c->n_subtitles).
Because it is checked to subtitles, not audio.
Signed-off-by: liuqi05 <liuqi05 at kuaishou.com>
> http://git.videolan.org/gitweb.cgi/ffmpeg.git/?a=commit;h=29ef547c16cdfc6d4dfe71400e17cee13c9ff399
---
libavformat/dashdec.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/libavformat/dashdec.c b/libavformat/dashdec.c
index 9262e9c0a4..3fd657c06b 100644
--- a/libavformat/dashdec.c
+++ b/libavformat/dashdec.c
@@ -155,6 +155,7 @@ typedef struct DASHContext {
/* Flags for init section*/
int is_init_section_common_video;
int is_init_section_common_audio;
+ int is_init_section_common_subtitle;
} DASHContext;
@@ -2084,11 +2085,11 @@ static int dash_read_header(AVFormatContext *s)
}
if (c->n_subtitles)
- c->is_init_section_common_audio = is_common_init_section_exist(c->subtitles, c->n_subtitles);
+ c->is_init_section_common_subtitle = is_common_init_section_exist(c->subtitles, c->n_subtitles);
for (i = 0; i < c->n_subtitles; i++) {
rep = c->subtitles[i];
- if (i > 0 && c->is_init_section_common_audio) {
+ if (i > 0 && c->is_init_section_common_subtitle) {
ret = copy_init_section(rep, c->subtitles[0]);
if (ret < 0)
goto fail;
More information about the ffmpeg-cvslog
mailing list