[FFmpeg-cvslog] avfilter/vf_noise: rename linesize to bytewidth

Michael Niedermayer git at videolan.org
Fri Sep 13 13:49:10 CEST 2013


ffmpeg | branch: master | Michael Niedermayer <michaelni at gmx.at> | Fri Sep 13 11:29:28 2013 +0200| [126ba688267eaea3bd1a3852e146aeb1237728d3] | committer: Michael Niedermayer

avfilter/vf_noise: rename linesize to bytewidth

Its the width in bytes and not the linesize or stride.
This makes the naming more consistent with the rest of the codebase

Signed-off-by: Michael Niedermayer <michaelni at gmx.at>

> http://git.videolan.org/gitweb.cgi/ffmpeg.git/?a=commit;h=126ba688267eaea3bd1a3852e146aeb1237728d3
---

 libavfilter/vf_noise.c |    6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/libavfilter/vf_noise.c b/libavfilter/vf_noise.c
index 9e82976..bd5b6f0 100644
--- a/libavfilter/vf_noise.c
+++ b/libavfilter/vf_noise.c
@@ -56,7 +56,7 @@ typedef struct {
 typedef struct {
     const AVClass *class;
     int nb_planes;
-    int linesize[4];
+    int bytewidth[4];
     int height[4];
     FilterParams all;
     FilterParams param[4];
@@ -190,7 +190,7 @@ static int config_input(AVFilterLink *inlink)
 
     n->nb_planes = av_pix_fmt_count_planes(inlink->format);
 
-    if ((ret = av_image_fill_linesizes(n->linesize, inlink->format, inlink->w)) < 0)
+    if ((ret = av_image_fill_linesizes(n->bytewidth, inlink->format, inlink->w)) < 0)
         return ret;
 
     n->height[1] = n->height[2] = FF_CEIL_RSHIFT(inlink->h, desc->log2_chroma_h);
@@ -377,7 +377,7 @@ static int filter_slice(AVFilterContext *ctx, void *arg, int jobnr, int nb_jobs)
         noise(td->out->data[plane] + start * td->out->linesize[plane],
               td->in->data[plane]  + start * td->in->linesize[plane],
               td->out->linesize[plane], td->in->linesize[plane],
-              s->linesize[plane], start, end, s, plane);
+              s->bytewidth[plane], start, end, s, plane);
     }
     return 0;
 }



More information about the ffmpeg-cvslog mailing list