[FFmpeg-cvslog] r17069 - in trunk/libavutil: base64.c base64.h
stefano
subversion
Sun Feb 8 22:13:11 CET 2009
Author: stefano
Date: Sun Feb 8 22:13:11 2009
New Revision: 17069
Log:
Cosmetics: prefer out/in over buf/src for the parameters names of
av_base64_decode, for consistency/readability reasons.
Modified:
trunk/libavutil/base64.c
trunk/libavutil/base64.h
Modified: trunk/libavutil/base64.c
==============================================================================
--- trunk/libavutil/base64.c Sun Feb 8 22:09:50 2009 (r17068)
+++ trunk/libavutil/base64.c Sun Feb 8 22:13:11 2009 (r17069)
@@ -69,7 +69,7 @@ int av_base64_decode(uint8_t * out, cons
* Fixed edge cases and made it work from data (vs. strings) by Ryan.
*****************************************************************************/
-char *av_base64_encode(char * buf, int buf_size, const uint8_t * src, int size)
+char *av_base64_encode(char *out, int out_size, const uint8_t *in, int size)
{
static const char b64[] =
"ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789+/";
@@ -79,11 +79,11 @@ char *av_base64_encode(char * buf, int b
int bytes_remaining = size;
if (size >= UINT_MAX / 4 ||
- buf_size < (size+2) / 3 * 4 + 1)
+ out_size < (size+2) / 3 * 4 + 1)
return NULL;
- ret = dst = buf;
+ ret = dst = out;
while (bytes_remaining) {
- i_bits = (i_bits << 8) + *src++;
+ i_bits = (i_bits << 8) + *in++;
bytes_remaining--;
i_shift += 8;
Modified: trunk/libavutil/base64.h
==============================================================================
--- trunk/libavutil/base64.h Sun Feb 8 22:09:50 2009 (r17068)
+++ trunk/libavutil/base64.h Sun Feb 8 22:13:11 2009 (r17069)
@@ -34,6 +34,6 @@ int av_base64_decode(uint8_t * out, cons
* @param src data, not a string
* @param buf output string
*/
-char *av_base64_encode(char * buf, int buf_size, const uint8_t * src, int size);
+char *av_base64_encode(char *out, int out_size, const uint8_t *in, int size);
#endif /* AVUTIL_BASE64_H */
More information about the ffmpeg-cvslog
mailing list